Banner

Problem mit Realtek Treibern bei Upgrade auf Squeeze

Heute habe ich das Backup System von Lenny auf Squezze geupdatet. Das Upgrade verlief ohne Probleme. Für alle, die jenes Upgrade noch vorhaben, kann ich nur die offiziellen Informationen hierzu von Debian empfehlen. Stark verkürzte Zusammenfassungen findet sich wie Sand am Meer in der Blogosphäre oder Foren, um nur diese als Beispiel zu nennen.

Das Problem

Doch zurück zum Hauptthema: Ich hatte vergessen die sources.list auf contrib non-free zu setzen und deshalb wurden die Realtek Firmware für meine Netgear GA311 Netzwerkkarte nicht mit installiert, das führte zuerst zu folgender Meldung:

 │ Benötigte Firmware-Dateien möglicherweise nicht vorhanden                 │ 
 │                                                                           │
 │ Auf diesem System läuft derzeit Linux 2.6.26-2-686 und Sie installieren   │
 │ gerade Linux 2.6.32-5-686. In der neuen Version könnten einige Treiber,   │
 │ die auf diesem System verwendet werden, zusätzliche Firmware-Dateien      │
 │ benötigen:                                                                │
 │                                                                           │
 │ r8169: rtl_nic/rtl8168d-2.fw, rtl_nic/rtl8168d-1.fw                       │
 │                                                                           │
 │ Die meisten Firmware-Dateien sind nicht im System enthalten, da sie       │
 │ nicht mit den Debian-Richtlinien für Freie Software (DFSG) konform sind.  │
 │ Sie müssen unter Umständen den Paketmanager neu konfigurieren, so dass    │
 │ die contrib- und non-free-Sektionen des Paketarchivs ebenfalls enthalten  │
 │ sind, bevor Sie diese Firmware-Dateien installieren können.               │

und später zu massenweise Hinweisen dieser Art:

Running update-initramfs.
update-initramfs: Generating /boot/initrd.img-2.6.32-5-686
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169

Die Lösung

Im Endeffekt habe ich (vor dem Reboot nach dem Upgrade) die /etc/apt/sources.list leicht angepasst:

deb http://ftp.de.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.de.debian.org/debian/ squeeze main contrib non-free

deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free
deb-src http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free

...und die Paketquellen aktualisiert:

user@server:~$ sudo apt-get update

Anschließend habe ich das Paket firmware-realtek installiert:

user@server:~$ sudo apt-get install firmware-realtek

...sowie die initramfs-tools geupdatet:

user@server:~$ sudo update-initramfs -u

Beim nächsten Reboot war das Problem behoben und die Netzwerkkarte konnte wieder genutzt werden.



RSSfeed

Hat dir dieser Artikel weiter geholfen? Abonniere neue Beiträge dieses Blogs per RSS-Feed.

Bist du an der Entwicklung dieses Projektes interessiert? Dann folge uns doch auf Twitter!

Der Autor dieses Beitrags würde sich sehr freuen, wenn du ihm einen Kommentar hinterlassen würdest.

Kommentar schreiben


Sicherheitscode
Aktualisieren

Anmelden

Suche

Neuste Kommentare

RSS
Copyright © 2009-2016 mein.homelinux.com

Creative Commons License